10074
Give your opinion
Read all reviews
Add to notepad
Print
  • 3.8/5
  • 1
  • 2
  • 3
  • 4
  • 5
Details
China Equipment goods

Report abuse

Equipment goods

Adsl modem

1)Full Rate ADSL 2+,Support Various Mainstream DSLAM 2)up to 24Mbps Downstreamand 1Mbps Upstream Date rate 3)The max distance is up to 5.4 Kilometers. 4)Support RFC 1483 BRIDGE 5)Support Classical IP over ATM (RFC1577) 6)Support PPP over ATM (RFC2364) 7)Plug and Play, USB 2.0/1.1 specification 8)Support PPP over Ethernet (RFC2516) 9)1 Ethernet,RJ11 and USB port.
Location : Room 3-205, No. 65, Da He Tou Rd., Ningbo, Zhejiang, China, 315012 Ningbo,
Contact : Yee Shalom, 086 0574 27661500

sanmoo

  • 3.6/5
Retail
Registered since 11 May 2007

Website : www.sanmoo-online.com

sanmoo

Good deal: buying from seller

Visit our guide for a secure transaction! Under no circumstances Algomtl can be held responsible for the content of the ads published. Only the sellers and buyers responsability is involved in case of dispute.
We invite you to read our terms of use. You can also visit our FAQ section and see our information section on the risks associated with counterfeiting.
This page is about importers and exporters of
Adsl modem

Search in a category : Equipment goods
Search in a category :
modem, adsl
  • 2.7/5
  • 1
  • 2
  • 3
  • 4
  • 5
France 75015 Environment / Ecology

Report abuse

Lampe de rue solaire - Série INTERSTELLAR - 100 Watts - 9000 Lumens - 90 Lumens/Watt -...
Lampe de rue solaire - Série INTERSTELLAR - 100 Watts - 9000 Lumens - 90 Lumens/Watt -...

Thursday, December 23, 2021

France Vision Distribution spécialiste de l'import / export, déstockage et produits High-tech. Nous proposons une large gamme de produits a forte demande, contactez nous et visitez notre site internet pour plus d'informations. Site : www.france-vision-distribution.com Téléphone :...

France Vision Distribution

  • 75015 - Paris
  • 09 74 55 07 59
  • 2.6/5
  • 1
  • 2
  • 3
  • 4
  • 5
Germany 60386 Phones

Report abuse

Samsung Galaxy Tab S7+ WIFI 256GB Mystic Noir T970N
Samsung Galaxy Tab S7+ WIFI 256GB Mystic Noir T970N

Thursday, June 23, 2022

Quantity : 100

Découvrez la Galaxy Tab S7+ . Profitez de son écran à 120Hz, et d'un processeur ultra-puissant pour révéler tout votre potentiel aussi bien dans votre productivité quotidienne que lors de vos meilleures parties de jeux vidéo. Retrouvez un véritable environnement de travail en connectant...

MaKant Europe GmbH & Co. KG

  • 60386 - Frankfurt am Main
  • +49 (69) 9 150 750 14
  • 2.8/5
  • 1
  • 2
  • 3
  • 4
  • 5
France 78600 Sport goods

Report abuse

Yoga Mat Exercise Fitness Mat High Density Non-Slip TPE
Yoga Mat Exercise Fitness Mat High Density Non-Slip TPE

Tuesday, December 07, 2021

Quantity : 7000 - Price : 3.90€ HT

De 300 pièces à 900 pièces = 5.90€ HT par pièce + Frais de Livraison 1 000 pièces et plus = 4.90€ HT par pièce + Frais de Livraison 3 000 pièces et plus = 3.90€ HT par pièce + Frais de Livraison Nos prix sont indiqués en HT et soumis à TVA 20% Commande minimum : 300 pièces Tapis de...

NOAH INVEST

  • 78600 - MAISONS-LAFFITTE
  • +33 6 74 93 88 34